# Extending ACCESS-OM2-025 RYF run present on ik11

**URL:** <https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689>\
**Category:** COSIMA\
**Tags:** help, solved\
**Created:** [15 September 2024 12:18 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689 "2024-09-15T12:18:46Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dhruv\_Bhagtani](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/dhruv_bhagtani/32/302_2.png) [@Dhruv\_Bhagtani](https://forum.access-hive.org.au/u/Dhruv_Bhagtani)\
**Post date:** [15 September 2024 12:18 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/1 "2024-09-15T12:18:46Z")

</div>

Hi,

I’m trying to extend the ACCESS-OM2 0.25 deg RYF run that’s been run for 600+ years, with outputs and restarts present in `/g/data/ik11/outputs/access-om2-025/025deg_jra55_ryf9091_gadi`

I am using the configuration files in `/g/data/ik11/configs/access-om2-025/025deg_jra55_ryf9091_gadi`. I had to make one change in the `config.yaml` file: instead of `/g/data4/ik11/inputs/access-om2/input_rc/`, I am using `/g/data4/ik11/inputs/access-om2/input_rc-DELETE/`. Everything else is exactly the same.

This updated config version is kept in `/home/156/db6174/access-om2/025deg_jra55_ryf_control-test` for anyone to have a look. This config gives the following error:

```auto
Currently Loaded Modulefiles:

1) pbs 2) openmpi/4.1.4(default)

ERROR: Unable to locate a modulefile for 'openmpi-mofed4.7-pbs19.2/4.0.1'

ERROR: Unable to locate a modulefile for 'openmpi-mofed4.7-pbs19.2/4.0.1'

ERROR: Unable to locate a modulefile for 'openmpi-mofed4.7-pbs19.2/4.0.1'

payu: Model exited with error code 1; aborting.

```

My guess is that since this config is 4-5 years old, module versions have been updated, which this config is unable to load. Has anyone encountered this error before or have suggestions?

Thanks!

---

<div class="post-metadata">

**Author:** ![rmholmes](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/rmholmes/32/117_2.png) [@rmholmes](https://forum.access-hive.org.au/u/rmholmes)\
**Post date:** [15 September 2024 23:00 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/2 "2024-09-15T23:00:01Z")

</div>

@Dhruv_Bhagtani I’m not sure the configuration files in `/g/data/ik11/configs/access-om2-025/025deg_jra55_ryf9091_gadi` are kept up to date.

On the [ACCESS-OM2 control runs hive forum post](https://forum.access-hive.org.au/t/access-om2-control-experiments/258?page=2) it says the configuration used is [this one](https://github.com/rmholmes/025deg_jra55_ryf/tree/ryf9091_gadi). That doesn’t seem to refer to `input_rc`, rather referring to `input_20200530`. Can you have a go with those configs?

That said, it might not fix your modules issue…

---

<div class="post-metadata">

**Author:** ![Dhruv\_Bhagtani](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/dhruv_bhagtani/32/302_2.png) [@Dhruv\_Bhagtani](https://forum.access-hive.org.au/u/Dhruv_Bhagtani)\
**Post date:** [16 September 2024 00:22 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/3 "2024-09-16T00:22:43Z")

</div>

Thanks Ryan! This config seems to be working well, no more module version issues now!

---

<div class="post-metadata">

**Author:** ![aekiss](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/aekiss/32/46_2.png) [@aekiss](https://forum.access-hive.org.au/u/aekiss)\
**Post date:** [16 September 2024 00:38 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/4 "2024-09-16T00:38:03Z")

</div>

Hi @Dhruv_Bhagtani if you want to extend the run you should clone the final configuration of the previous run so that everything is the same. You could use the `ryf9091_gadi` branch from here [GitHub - rmholmes/025deg\_jra55\_ryf at ryf9091\_gadi](https://github.com/rmholmes/025deg_jra55_ryf/tree/ryf9091_gadi) or @rmholmes’s control directory on Gadi if that’s still around. To be really sure, it’s a good idea to re-do the final run and check that the restarts in the manifests in your new run are the same as before. See  
[Tutorials · COSIMA/access-om2 Wiki · GitHub](https://github.com/COSIMA/access-om2/wiki/Tutorials#starting-a-new-experiment-using-restarts-from-a-previous-experiment)

---

<div class="post-metadata">

**Author:** ![Dhruv\_Bhagtani](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/dhruv_bhagtani/32/302_2.png) [@Dhruv\_Bhagtani](https://forum.access-hive.org.au/u/Dhruv_Bhagtani)\
**Post date:** [16 September 2024 05:52 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/5 "2024-09-16T05:52:35Z")

</div>

Good idea!

---

<div class="post-metadata">

**Author:** ![sschroeter](https://avatars.discourse-cdn.com/v4/letter/s/f17d59/32.png) [@sschroeter](https://forum.access-hive.org.au/u/sschroeter)\
**Post date:** [29 September 2024 03:17 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/6 "2024-09-29T03:17:37Z")

</div>

@rmholmes I’m having a similar issue with this module error - in my case, I’m trying for a warm start to do some perturbation experiments. The intention is to start at restart250, and I’ve updated the configs to point at the input\_20200530 as per your suggestion. The manifests show the correct filepaths as far as I can tell, but the job is still returning the same module error that @Dhruv_Bhagtani was originally finding. What else can I try?

---

<div class="post-metadata">

**Author:** ![rmholmes](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/rmholmes/32/117_2.png) [@rmholmes](https://forum.access-hive.org.au/u/rmholmes)\
**Post date:** [30 September 2024 00:01 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/7 "2024-09-30T00:01:17Z")

</div>

Hi Serena,

I’ve never encountered that module issue before. I wonder if there are other differences between your configuration files and the ones used for the original run? I would suggest doing a comparison. By working forwards from the original configuration files I’ve linked above (which seem to have worked for @Dhruv_Bhagtani ) you might be able to narrow down the issue? Let me know if that doesn’t help and I can look into it in more detail.

---

<div class="post-metadata">

**Author:** ![Dhruv\_Bhagtani](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/dhruv_bhagtani/32/302_2.png) [@Dhruv\_Bhagtani](https://forum.access-hive.org.au/u/Dhruv_Bhagtani)\
**Post date:** [30 September 2024 00:45 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/8 "2024-09-30T00:45:55Z")

</div>

Hi Serena, I would also suggest starting from the original configuration files and making sure that all exe and input files are the same.

---

<div class="post-metadata">

**Author:** ![Aidan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/aidan/32/42_2.png) [@Aidan](https://forum.access-hive.org.au/u/Aidan)\
**Post date:** [1 October 2024 00:46 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/9 "2024-10-01T00:46:21Z")

</div>

3 posts were merged into an existing topic: [Extending ACCESS-OM2-025 RYF runs on ik11](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-runs-on-ik11/3741/5)

---

<div class="post-metadata">

**Author:** ![anton](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/anton/32/1836_2.png) [@anton](https://forum.access-hive.org.au/u/anton)\
**Post date:** [15 January 2025 21:34 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/10 "2025-01-15T21:34:05Z")

</div>

> [@Dhruv\_Bhagtani](#):
>
> My guess is that since this config is 4-5 years old, module versions have been updated, which this config is unable to load.

The original error “Unable to locate a modulefile” is a bit of a red-herring, and doesn’t stop the config running.

As @aidan explains [here](https://forum.access-hive.org.au/t/perturbation-experiments-forked-from-access-om2-025-ryf-control-run-on-ik11/3741/8), payu tries to find the module file for openmpi that the model was compiled against. However this versions doesn’t exist anymore. Payu does find a newer openmpi (4.1.4) and loads that and the model can run but was failing for a different reason.

---

<div class="post-metadata">

**Author:** ![anton](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/anton/32/1836_2.png) [@anton](https://forum.access-hive.org.au/u/anton)\
**Post date:** [15 January 2025 22:08 UTC](https://forum.access-hive.org.au/t/extending-access-om2-025-ryf-run-present-on-ik11/3689/11 "2025-01-15T22:08:42Z")

</div>


