# MOM6 regional crashing with layout error

**URL:** <https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780>\
**Category:** COSIMA\
**Created:** [6 February 2024 00:52 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780 "2024-02-06T00:52:12Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![ChrisC28](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/chrisc28/32/299_2.png) [@ChrisC28](https://forum.access-hive.org.au/u/ChrisC28)\
**Post date:** [6 February 2024 00:52 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/1 "2024-02-06T00:52:12Z")

</div>

HI all,

I’ve been banging my head against the wall for a couple of days an have convinced myself I’m making a relatively simple error.

I’m attempting to run a custom regional MOM6 configuration, developed using @ashjbarnes tools.

When I run the model on Setonix, I get the following error:

> mpp\_domains\_define.inc: At least one pe in pelist is not used by any tile in the mosaic

I’m run the test configuration with 128 cores, and I’ve check that the MOM\_LAYOUT matches the requests resources. I’ve regenerated the solo mosaic and quick mosaics (as I’m in the middle of the Pccific ocean, no tiles are masked as there is not enough land).

Does anyone out there have any advice? Thanks all!

---

<div class="post-metadata">

**Author:** ![angus-g](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/angus-g/32/89_2.png) [@angus-g](https://forum.access-hive.org.au/u/angus-g)\
**Post date:** [7 February 2024 04:42 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/2 "2024-02-07T04:42:18Z")

</div>

I haven’t seen that before, but given that it’s happening in the atmosphere initialisation, I wonder if you should include an explicit layout for the null components in your `input.nml`. Either `0,0` or `10,10`, I’m not sure if it can be explicitly empty, or if it should match your processor count:

```auto
&atmos_model_nml
    layout = 0, 0
/
&land_model_nml
    layout = 0,0
/

```

---

<div class="post-metadata">

**Author:** ![ChrisC28](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/chrisc28/32/299_2.png) [@ChrisC28](https://forum.access-hive.org.au/u/ChrisC28)\
**Post date:** [8 February 2024 23:19 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/3 "2024-02-08T23:19:15Z")

</div>

Thanks @angus-g I gave it a try but, unfortunately, no luck.

I’m wondering if this is either a Setonix thing, or a problem when trying to run the model without a processor land mask?

---

<div class="post-metadata">

**Author:** ![Aidan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/aidan/32/42_2.png) [@Aidan](https://forum.access-hive.org.au/u/Aidan)\
**Post date:** [9 February 2024 03:11 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/4 "2024-02-09T03:11:56Z")

</div>

Can you push your config to GitHub? Would that help for others to assist diagnosing the problem?

---

<div class="post-metadata">

**Author:** ![john\_reilly](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/john_reilly/32/237_2.png) [@john\_reilly](https://forum.access-hive.org.au/u/john_reilly)\
**Post date:** [13 February 2024 01:45 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/5 "2024-02-13T01:45:00Z")

</div>

Hi Chris,

Just a thought but could it possibly be associated with a MOM6 executable difference? As far as I understand, @ashjbarnes has `mom6-regional` setup to be using a more recent ocean-only executable? I was hoping to get him to help us compile this on Setonix some time soon.

---

<div class="post-metadata">

**Author:** ![ChrisC28](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/chrisc28/32/299_2.png) [@ChrisC28](https://forum.access-hive.org.au/u/ChrisC28)\
**Post date:** [13 February 2024 06:27 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/6 "2024-02-13T06:27:02Z")

</div>

Hi all,

Thanks for the suggestion @john_reilly . This may indeed be an issue. Maybe @angus-g or @ashjbarnes could comment.

The configuration was created using the current version of @ashjbarnes tool (cloned directly from github). I’m not sure what, if any, difference using the ocean only (versus the MOM6-SIS executable) would make.

I’ve been in a workshop all day, but push my config tomorrow to GitHub.

---

<div class="post-metadata">

**Author:** ![ChrisC28](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.access-hive.org.au/chrisc28/32/299_2.png) [@ChrisC28](https://forum.access-hive.org.au/u/ChrisC28)\
**Post date:** [15 February 2024 05:39 UTC](https://forum.access-hive.org.au/t/mom6-regional-crashing-with-layout-error/1780/7 "2024-02-15T05:39:15Z")

</div>

Well, with help from @ashjbarnes and @john_reilly we were able to find that the source of the problem was my own incompetence: no mask and moasic files were being produced and included in the INPUT directories, which tripped up the MOM6 at atmospheric initialization.

Potential trap for if you are running a domain in the open ocean with few continents/large islands to be aware of.
