UM Nesting Suite - SST ancillary not being used?

Hi everyone,

I’m trying to run the RNS with a modified SST ancillary file, but the SST ancillary doesn’t appear to be used. There is a note under the sstsmc_anc option (make extra SST and SMC ancillaries) that says ‘these extra ancillaries are not used by the default version of the nesting suite’.

Any tips on how to change this?

Thank you!

You can add more ancil files under um > namelist > Configure ancils .... Right click in the table and add a new section, then right click the new entry and select ‘view this section’.

The setup should look something like this - SST goes to stash 24. For a climate run you’d set it to update the sst every so often from the ancil file, but that’s probably not needed in a regional run.

1 Like

Thanks Scott!

The modified SST ancillary will have daily mean values so will need to update the SST. I’ve set the update interval to 1 day but the um_fcst step is failing with an error message
INANCILA: Insifficient space for LOOKUP headers.

I’ve tried increasing nancil_lookupsa but it then fails with the following?

@BecJackson has this been resolved? If not, can you provide instructions on how to reproduce your error? Also just for future note, please try to avoid posting screenshots of errors and instead include them as plain text so that they are searchable.

1 Like

Hi Sean,

No this hasn’t been solved yet.

I’ve added the SST ancillary to the Configure ancils table as @Scott mentioned above. The suite runs fine when update_anc = False, with either a monthly (created by the RAS) or daily mean (modified from monthly file) SST ancil, but when I try to update the SST field (update_anc = True) I get the below error regardless or which update period I use (1 day, month etc).

Any help would be really appreciated!


in job.err:

[14] exceptions: An exception was raised:11 (Segmentation fault)
[14] exceptions: the exception reports the extra information: Invalid permissions for mapped object.
[14] exceptions: whilst in a serial region
[14] exceptions: Task had pid=1452650 on host
[14] exceptions: Program is “um-atmos.exe”
[14] exceptions: calling registered handler @ 0x00416350
Warning in umPrintMgr: umPrintExceptionHandler : Handler Invoked
[9] exceptions: Done callbacks
[9] exceptions: *** GLIBC ***
[9] exceptions: Data address (si_addr): 0x149ad37f18c8; rip: 0x00534dc2
[0] exceptions: [backtrace]: ( 13) : Address: [0x004089de]
[0] exceptions: [backtrace]: ( 13) : line information unavailable error code: 4 (Program name & path is not absolute)
[0] exceptions:
[0] exceptions: To find the source line for an entry in the backtrace;
[0] exceptions: run addr2line --exe=</path/too/executable>
[0] exceptions: where address is given as [0x] above
[0] exceptions:
[0] exceptions: Done backtrace

Primary job terminated normally, but 1 process returned
a non-zero exit code. Per user-direction, the job has been aborted.

mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

Process name: [[55497,1],18]
Exit code: 11

[FAIL] um-atmos # return-code=11
Loading cylc7/23.03
Loading requirement: mosrs-setup/1.0.1
2023-10-02T22:58:37Z CRITICAL - failed/EXIT

There’s a limit to the number of 2d field slices the model will read from an ancil file, I can’t remember the exact figure but it should be at least a couple thousand. What’s in your file? If it’s like a decade of daily data or something like that you may need to break it up into multiple sections.

1 Like

Thanks @Scott! The modified ancil file contains daily data for 1 year. I thought the issue might be the date format (eg 2018-01-01 instead of some reference year?), but I get the same error when using the default monthly ancil file created by the RAS, regardless of which update period I set.

Here’s whats in the ancil file:

Thanks for all of your help with this!

Ok, that looks fine. What are your model run dates?

Trying to run a test for 1 - 3 January 2018 at this stage

Hello @BecJackson, thanks for your post, how’d you go?
If resolved, can you please mark one of the posts as a solution or summarise a resolution that worked for you? Cheers

Hi @Flick, still working on a solution but will post here if I find one!

1 Like

Hi Bec,

Try adding the sea ice ancillary as well, it appears both are required if one is present. A climatology should be fine, e.g.

1 Like

Thanks so much @Scott, that’s all working now!

1 Like

The complete solution was given by @Scott in these two posts:
How to add generic ancils:

How to add Sea Ice ancils:

1 Like