ACCESS-CM2 setup and tutorial issues/problems

Apologies if this is the wrong forum.
I am trying to setup the ACCESS-CM2 model to eventually run some pacemaker style experiments. I have set up the model according to these instructions.

To become familiar with the model and how it works I have been following this tutorial.
but have encountered an error I’m not sure how to fix or resolve. The tutorial says I should encounter an error but at the coupling stage which is not yet reached.

When I try rose suite-run I find that it fails at fcm_make_drivers. this is the error sent in the email
“failed: 18500101/fcm_make_drivers/01”

In the job.err file this is what we see

[FAIL] config-file=/home/561/sm2435/cylc-run/u-cs844/work/18500101/fcm_make_drivers/fcm-make.cfg:4
[FAIL] config-file= -
[FAIL] cannot load config file
[FAIL] not found
[FAIL] svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
[FAIL] svn: E215004: Unable to connect to a repository at URL ''
[FAIL] svn: E215004: No more credentials or we tried too many times.
[FAIL] Authentication failed

[FAIL] fcm make -f /home/561/sm2435/cylc-run/u-cs844/work/18500101/fcm_make_drivers/fcm-make.cfg -C /home/561/sm2435/cylc-run/u-cs844/share/fcm_make_drivers -j 4 mirror.prop{}=2 # return-code=1
2022-12-14T00:15:39Z CRITICAL - failed/EXIT

If you have any input or ideas on how to fix this please reach out!

1 Like

The CM2 suite uses driver scripts from a separate NCI repository (a design decision I now regret).

On accessdev, run access-auth to cache your NCI password for this repo and then run the suite.

Minor point @sebmckenna, but would you mind if I moved this topic to the Climate category? We’re still in the start-up phase of the forum and new members will look to existing topics to decide where to put their queries, and I think this would be a great example for Climate.


Thanks @MartinDix I tried that but I am still getting the same error. I think this config file in the error messagedoesn’t actually exist at
The file drivers.cfg is there but not drivers.cfg@704

@aidanheerdegen yeah please move the topic if it fits better there

1 Like

The 704 is specifying the revision number. Does this work from the command line for you?

accessdev:% svn ls
1 Like

Yes it does. I had to enter my password though, maybe access-auth didn’t save credentials properly?

I tried to run the setup again and fcm_make_drivers worked this time

access-auth doesn’t check the password. I sometimes put my MOSRS password in by mistake and get confused when things don’t work.