Compiling ACCESS-ESM1-5

Hi folks,

I’m trying to compile ACCESS-ESM1-5. I’ve found a build script here: /g/data/p66/tfl561/source_ACCESS-ESM1-5/UM/compile/UM_exe_generator-ACCESS1.5 but it seems it was intended for raijin.

I’ve tried to adapt the module loads to gadi. So far I’ve gotten it to build up to the linking stage, then it says:
/bin/ld: cannot find -ldummygrib

dummygrib was loaded as a module in raijin but gadi does not have this module as far as I can see.

What is this library? Why can’t I find it on gadi if it’s used by ACCESS?


1 Like

Hi Tam,

I’ll put my build script on scratch for you. It will resolve these issues :slight_smile :slight_smile:


Hey Tam,

The plots you showed of thinning – can you show me what you plotted?

Internal to CABLE it is zero-ed every first timestep which is an obvious culprit. But the strange part is that I can’t find it making its way out of CABLE!!



1 Like

See Wood thinning in ACCESS - #2 by tammasloughran

I found a static library for dummygrib here:


I added this directory to the compiler flags in my fcm config file (-L/g/data/access/apps/dummygrib) and it worked.

I understand that the ACCESS-NRI are planning to release an official build pipeline for ACCESS-ESM1-5 in the near future so the build script I shared above will likely be redundant soon.

As an aside, I was looking at the compiler flags in the fcm config file and it looks like many components of the UM are compiled without any compile-time optimizations (the standard config file, not the debug one). There might be a good reason for this that I’m not aware of. Great for debugging, but not so much for speed.

1 Like