Payu setup error with mom6-panan

Hi folks,

I am trying to get GitHub - COSIMA/mom6-panan at panan-01-zstar-run to run. I have done the following:

git clone GitHub - COSIMA/mom6-panan: Pan-Antarctic regional configuration of MOM6 panan-01-zstar
cd panan-01-zstar/
git checkout -t origin/panan-01-zstar-run
edit the config.yaml
payu setup
laboratory path: /scratch/jk72/pas561/mom6
binary path: /scratch/jk72/pas561/mom6/bin
input path: /scratch/jk72/pas561/mom6/input
work path: /scratch/jk72/pas561/mom6/work
archive path: /scratch/jk72/pas561/mom6/archive
Traceback (most recent call last):
File “/g/data3/hh5/public/apps/miniconda3/envs/analysis3-22.07/bin/payu”, line 10, in
File “/g/data/hh5/public/apps/miniconda3/envs/analysis3-22.07/lib/python3.9/site-packages/payu/”, line 42, in parse
File “/g/data/hh5/public/apps/miniconda3/envs/analysis3-22.07/lib/python3.9/site-packages/payu/subcommands/”, line 24, in runcmd
expt = Experiment(lab, reproduce=reproduce, force=force)
File “/g/data/hh5/public/apps/miniconda3/envs/analysis3-22.07/lib/python3.9/site-packages/payu/”, line 109, in init
init_script = self.userscripts.get(‘init’)
AttributeError: ‘NoneType’ object has no attribute ‘get’

Why am I getting this payu setup error? Not that Matthis has followed the above steps as well and doesn’t get this payu setup error. Do I need to update payu?


1 Like

It looks like you have a problem with your config.yaml:

        #   archive: qsub

You’ll need to comment out the userscripts line too, if you want to disable the gdata syncing.