Mosrs-auth not working after maintenance

Hi Team,

@ZhangchengPei and I are having some issues with mosrs-auth today - see below. It looks like it has been updated, so does anyone know what we need to do to get it working?


[slf563@gadi-login-04 ~]$ module load cylc7
Using the cylc session

Loading cylc7/24.03
  Loading requirement: mosrs-setup/2.0.0
[slf563@gadi-login-04 ~]$ mosrs-auth 
MOSRS username sonyafiddes - change in ~/.subversion/servers
Current project jk72
gpg-connect-agent: no running gpg-agent - starting '/usr/bin/gpg-agent'
gpg-connect-agent: waiting for the agent to come up ... (5s)
gpg-connect-agent: connection to agent established
Checking stored password...
svn: E170013: Unable to connect to a repository at URL ''
svn: E215004: No more credentials or we tried too many times.
Authentication failed
ERROR checking password
Command '['svn', 'info', '', '--non-interactive']' returned non-zero exit status 1.

‘Mosrs-auth’ can work with older version of cylc7/23.09. But seems to have issue with the latest cylc7/24.03.

Try mosrs-auth --force to force it to renew the password

1 Like

Hi Scott - that does not seem to solve the problem - same errors as above. Loading cylc7/23.09 works for now, but would be good to have it working with the later releases?

Hi Sonya, try renaming the ~/.subversion directory to something else, like ~/.subversion.bak, then logging out and back in again. This sometimes fixes the problem.

I have also just tried to use mosrs-auth and failed. My suggestion of renaming ~/.subversion just made the problem worse. I have lodged HELP-194953 with NCI and have directed the request to Rui Yang.

As a workaround, use your original ~/.subversion directory, and revert to the previous mosrs-auth:

module unload cylc7/24.03
module unload mosrs-setup
module load cylc7/23.09

This worked for me.


Rui and I have just made an update to mosrs-auth that fixes a few issues

  • automatically creates ~/.subversion/auth directory
  • no longer remember invalid passwords
  • don’t create extra ~/.gnupg directories on compute nodes
  • Fixes module error where subversion couldn’t read the cached password

This is in module mosrs-auth/2.0.1, it’s the new default


Thanks @Scott

I just tried it, it works for me.

Nice new password interface.

1 Like

Works for me! Thanks Team!

1 Like

I have asked for HELP-194953 to be closed.