"Out of the box" ACCESS-ESM1.5 with payu not working

Hi all,

I know there has been discussion about this in other topics, but I just wanted to raise it here as its own topic to focus the discussion and hopefully to find a way forward.

I’ve tried running the ACCESS-ESM1.5 with both the pre-industrial and the historical configurations using payu, but both throw errors. For the pre-industrial I followed this GitHub - MartinDix/access-esm at pre-industrial. For the historical I followed this GitHub - coecms/access-esm: Main Repository for ACCESS-ESM configurations and performed a checkout on the “historical” branch.

You can see that I’ve raised an issue on the Github page here Historical run not working from Payu instruction · Issue #16 · coecms/access-esm · GitHub with some more details on the errors at hand.

Would there be someone at ACCESS-NRI that would be willing to look into this?

1 Like

I’ve encountered the same. I have an early-2023 version of the ESM pre-industrial configuration which worked. I think some restart files changed in the meantime which made it break. If you want to regress to a 2023 pre-industrial setup, I can send you mine.

Ah David that would be great. Yes please. Would it be possible for you to share the files/instructions so that anyone can come along and use your configuration? I’m aware that might be a lot to ask, so perhaps someone at ACCESS-NRI can also help make this work?

Hmmm… yes I know that ACCESS-NRI is working on a “re-release” of the ACCESS-ESM1.5 pre-industrial configuration. I think when that’s done it should provide a long-term solution to this issue.

I’m thinking if you just want something to test in the meantime (which came from the original repo before it broke.)

1 Like

Okay yes let’s just go with the latter: Something to use in the meantime. Really appreciate it. We are testing how the new WOMBAT goes in the ESM and would ideally like to have something running asap so that we can deal with errors/optimisation in the coming months.

Ok, so in fact I think I can suggest a small tweak to make the public repo version work rather than copy my stuff. Try this:

  1. Checkout the pre-industrial repo https://github.com/MartinDix/access-esm.git (I think you’ve done this already.)
  2. Make a local copy of the restart folder shown in Line 44 of the config.yaml. I do the following:
cp -rp /g/data/access/payu/access-esm/restart/pre-industrial /g/data/y99/dkh157/access_esm/restart/PI_test3

I highly recommend using cp -rp so you can keep the date stamps of the original files. (You will make your own location.)
3. Go to your local restart folder location. In it there should be an atmosphere folder. Go to that atmosphere folder, and you’ll see two files restart_dump.astart.bak and restart_dump.astart. You can see the date stamp of the backup one is from May 19 2020. That one works. The newer one doesn’t. So…
4. type

mv restart_dump.astart.bak restart_dump.astart

(I.e. overwrite the newer restart file with the backup.)
5. Go back to your run directory, and in config.yaml replace the directory in Line 44 with your new restart folder location. (Mine is /g/data/y99/dkh157/access_esm/restart/PI_test3)
6. Try running it again.


Can confirm that this works!

1 Like